Технические FAQs

Задать вопрос

Обновление клиентов CtAPI, чтобы получить совместимость с Vijeo Citect 2015

Резюме: С выпуском Vijeo Citect 2015 для обеспечения повышенной безопасности в ПО встроен новый механизм шифрования паролей. Из-за этого изменения рекомендуется обновить CtAPI и использовать новыйе DLL для Vijeo Citect 2015 (версия 7.50.xx).
Решение: Новое расширение шифрования пароля требует, чтобы удаленные клиенты CtAPI или программные средства сторонних производителей, которые используют CtAPI, должны быть обновлены, для получения совместимости.
Следующие требования к программному обеспечению должны быть выполнены перед обновлением файлов на удаленном клиенте CtAPI:
  • NET 4.5.1 (see supported OS here: https://msdn.microsoft.com/en­us/library/8z6watww(v=vs.110).aspx (https://msdn.microsoft.com/en­us/library/8z6watww(v=vs.110).aspx))
  • Microsoft Visual C++ 2012 Redistributable (x86) ­ 11.0.61030
Рекомендуется сделать резервную копию существующего приложения и существующих файлов CtAPI, прежде чем продолжить.
Скопировать вышеуказанные файлы в каталог Bin, перезапиывая старые файлы.
CTAPI.dll
CT_IPC.dll
CTENG32.dll
CTRES32.dll
CTUTIL32.dll
CIDEBUGHELP.dll
CTUTILMANAGEDHELPER.dll
Ниже перечислены директории программных продуктов компании Schneider Electric, которые используют CtAPI:
  • Ampla 5.2 ­> C:\Program Files(x86)\Citect\Ampla
  • Vijeo Historian 4.50 ­> C:\Program Files (x86)\Common Files\Schneider Electric Shared\OLEDB



 
Вы нашли ответ на свой вопрос?
Как мы можем улучшить информацию?